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TradeStationTM Interface via email notification 
The AutoX plugin supports capturing four types of strategy notifications, order type mapping (buy to 
cover to buy or sell short to sell), manual order confirmation, symbol mapping, advanced account 
assignment, and redirection of email notifications to user’s email client. In order for signals to be 
captured from TradeStationTM, the local SMTP port cannot be used by another process. Moreover, 
only one StoneX Futures Trader can capture signals per computer. 
 

TradeStationTM and StoneX Futures Trader Settings 

System requirements 

• If using AutoX on a server, please be sure that Windows SMTP service is disabled.  To 
check, open the Windows Control Panel and go to the Administrative Tools, then go to 
Services area.  Disable the Windows SMTP service, if it is installed and started: use a right 
click to open “Properties.”  Change “Startup type” to “Disabled” and press “Stop,” then OK. 

• If you use a SMTP service, please stop this service or re‐configure it to not use port 25.  Be 
sure to close all other TradeStationTM capture applications which use port 25. 

• Check your firewall settings and make sure the SMTP port is not blocked for local use. 
• Only one instance of StoneX Futures Trader can capture TradeStationTM signals (eg. Demo 

or Live but not both platforms running AutoX at once). 

StoneX Futures Trader 
1. From the menu bar of StoneX Futures Trader, go to File > Plugins > AutoX > Capture 

Settings: 
2. Fill out the “From:” field in the Email settings section with the same email address used in 

TradeStationTM Messaging, eg. autox@noreply.com. 
3. Check “Outgoing SMTP” box, if you want to redirect the TradeStationTM messages to your 

email client.  This is not necessary unless you require notification be redirected to your email. 
4. Check “Enabled” and adjust “Manual Confirmation” setting, if necessary. 
5. Set the appropriate mapping settings, explained in the next section of user guide on page 8. 
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Options Explained: 

Feature Description 

Enabled Start capturing TradeStationTM signals 

Manual Confirmation Asks for user a confirmation on all TradeStationTM 
reports. User can review corresponding order and send, 
modify or cancel, decline report and corresponding 
action, or allow it to execute corresponding action 
immediately 

Send market order on Filled report A market order will be sent, when a TradeStationTM 
Strategy order is filled. All other types from 
TradeStationTM reports are ignored and skipped. If the 
order is cancelled, no actions are performed at all. This 
option ensures the most accurate synchronization of 
positions (during this process, if positions are 
synchronized initially) 

Send signals AS‐IS StoneX Futures Trader sends an order that is identical 
to the TradeStationTM Strategy order description, with 
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Feature Description 

exception to short order type (“sell short” is treated as 
“sell”, “buy to cover” is treated as “buy”).   Because 
TradeStationTM order types and StoneX Futures Trader 
order types are filled in different environments, the 
TradeStationTM Strategy and StoneX Futures Trader 
positions could become unsynchronized. 

Send AS‐IS, but convert to market on 
Filled report 

The same as previous option, but a conditional order 
will be modified to a market order on a Filled report from 
TradeStationTM, if an StoneX Futures order is not filled 
in selected timeout. 
 
Modify to Market handled as limit.  Since our order 
gateway does not support modify requests to a Market 
order, this command would get rejected.  As a 
workaround, this option will adjust the limit price to 
simulate a market order. 

Desynchronization Timeout Displays an alert, if the StoneX Futures order has been 
filled, but the TradeStationTM Strategy order is still 
working (no incoming Filled report for this order). 

 

 

Note:  To decrease desynchronization of positions, a market order will be sent on a Filled report 
from TradeStationTM when the option “Send signals AS‐IS” is selected.  If the original order is 
rejected and the reason is related to trigger price, the rejection message will state “trigger price.” 

TradeStationTM 
1. Open the TraderManager window in TradeStationTM.  Go to File > New Window > Trade 

Manager or use the navigational pane on the right side. 
2. Open the Trader Manager Preferences via View in main menu of TradeStationTM. 
3. Set email notification for Strategy Active, Canceled, Filled and Replaced Order 
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4. Check “Enable e‐mail notification” and press “Configure...” 
 

 
 

5. In the message dialog box enter “autox@noreply.com” for the “From” and “to” email 
address fields, and “LOCALHOST” or “127.0.01” in “SMTP Server name” field, see image on 
next page.   
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(For TradeStationTM versions before 9.1 Update 12, enter settings like below) 

 

(For TradeStationTM version 9.1 Update 12 or later, enter settings like below) 
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Press OK and a prompt will appear to send a test message.  You will see dialog two windows: one 
from TradeStation and one from StoneX Futures Trader.  The message will confirm if the test has 
been sent and received.  If the message is not received, please check Firewall and Anti-virus 
settings. 

 

Options Explained: 

Feature Description 

Enabled Start capturing TradeStationTM signals 

Manual Confirmation Asks for user a confirmation on all TradeStationTM 
reports. User can review corresponding order and send, 
modify or cancel, decline report and corresponding 
action, or allow it to execute corresponding action 
immediately 

Send market order on Filled report A market order will be sent, when a TradeStationTM 
Strategy order is filled. All other types from 
TradeStationTM reports are ignored and skipped. If the 
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Feature Description 

order is cancelled, no actions are performed at all. This 
option ensures 
the most accurate synchronization of positions (during 
this process, if positions are synchronized initially) 

Send signals AS‐IS StoneX Futures Trader sends an order that is identical 
to the TradeStationTM Strategy order description, with 
exception to short order type (“sell short” is treated as 
“sell”, “buy to cover” is treated as “buy”).   Because 
TradeStationTM order types and StoneX Futures Trader 
order types are filled in different environments, the 
TradeStationTM Strategy and StoneX Futures Trader 
positions could become unsynchronized. 

Send AS‐IS, but convert to market on 
Filled report 

The same as previous option, but a conditional order 
will be modified to a market order on a Filled report from 
TradeStationTM, if a StoneX Futures order is not filled in 
selected timeout. 
 
Modify to Market handled as limit.  Since our order 
gateway does not support modify requests to a Market 
order, this command would get rejected.  As a 
workaround, this option will adjust the limit price to 
simulate a market order. 

Desynchronization Timeout Displays an alert, if the StoneX Futures order has been 
filled, but the TradeStationTM Strategy order is still 
working (no incoming Filled report for this order). 

 
Go back into StoneX Futures Trader and go to File > Plugins > AutoX > Capture Settings to 
configure additional settings.   
 
Messages and Notifications (optional) 
It is possible to redirect all incoming messages to a 3rd party SMTP‐enabled software or email 
accounts. Please check with your email provider for the host or server name, port, and if 
authentication is required.   AutoX can send the connection status and internal error notifications to 
the selected email addresses.  Additionally, it is possible to send SMS messages to cellular or 
mobile phones.   The user can simply type their cell phone number in the “Send error and 
connection notifications to:” field.  Use the following guide for assistance of what email address to 
use: 

Carrier Address 

AT&T 10digitphonenumber@txt.att.net 

Metro PCS 10digitphonenumber@mymetropcs.com 

Sprint 10digitphonenumber@messaging.sprintpcs.
com 



         
  

 

 9 

AutoX Setup Guide 

June 25, 2021 

 
 
 
 
 

If your carrier is not listed, please check: http://en.wikipedia.org/wiki/List_of_SMS_gateways  
 
Message and Notification Limitations  
 
The AutoX plugin currently only supports regular, non-secured SMTP connections. Secured 
connections like TLS (Transport Layer Security) and STARTTLS (as required by Gmail, for example) 
are not supported.  If the mail server requires SSL connection, you will get the following error:  
 

 
 

Mapping (required) 
There are two modes of mapping: Simple and Extended.  Simple mapping has two parts: one maps 
the workspace name to account and the other maps the symbols.  Each TradeStationTM  workspace 
is mapped separately.  The default symbol map is used for extended mapping only. 
 

 
 
  

T-Mobile 10digitphonenumber@tmomail.net 

US Cellular 10digitphonenumber@email.uscc.net  

Verizon 10digitphonenumber@vtext.com 

http://en.wikipedia.org/wiki/List_of_SMS_gateways
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Simple Mapping 

Account Selection  
This window maps the workspace name of the incoming signal(s) to an account number.  The 
signals from non‐defined workspaces are ignored.  Each workspace can only be assigned to one 
account or one allocation block name. 
 

 

Symbol Mapping: 
This window allows the mapping of the AutoX (TradeStationTM) symbol to the StoneX Futures Trader 
symbol.  Specifically, it maps corresponding TradeStationTM continuous symbols to specific StoneX 
Futures Trader symbols.  In the event of quotation differences, you may also adjust the sent price by 
using a Price Multiplier to reflect the price quoted by StoneX Futures Trader.  Each workspace has 
its own symbol mapping.  If the symbol is not defined in the mapping, its signals will be ignored.  
 
Price multiplier used 

 

 
Non-continuous mapping 
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Continuous mapping 

 
          

Extended Mapping 
This mode uses the incoming workspace name, AutoX symbol, and the interval to map to the 
StoneX Futures Trader account and contract.  To get started, click on the Extended tab and then 
click on Add. 
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There are several areas within extended mapping that can be configured. 

 

Workspace 

Pick the Workspace file used in 
TradeStationTM.  They are usually located 
in MyWork folder (eg. C:\Program 
Files\TradeStation 9.1\MyWork). 
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AutoX to StoneX Futures Symbol Mapping 

 
Enter the symbol used in the TradeStationTM platform as the AutoX symbol, eg. ESM12 and to the 
immediate right the StoneX Futures symbol, eg. ESM20.   
• If you wish to map the AutoX symbol to the base StoneX Futures symbol, select the radio box next to 

Symbol:.  Please be aware that this will map the AutoX symbol to the first month offered in the 
StoneX Futures data feed.  This may not necessarily be the active month traded.   

• If using the continuous symbol, it is usually mapped as ES and not @ES, even though your chart may 
display this formatting of symbol.  The reason for this is the TradeStationTM email notification sends 
us ES instead of @ES.  Be sure to use AutoX log window to see if adjustments will be necessary. 

• If you wish to use the default symbol map, from prior screen, select Any (default symbol map). 
 

 

Quantity Multiplier (typically used for Allocation Block Trading) 

 
This field allows you to increase the number of lots traded without having to adjust in TradeStationTM.  
This is typically used for Allocation Blocks.  When trading into an Allocation Block, you should match the 
Total Lots with Qty Multiplier and designate in account drop down the Allocation Block name.  If you 
make changes to the block, you must change the AutoX setting as well. 
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Interval: 

 
This field is used to map the extended AutoX mapping to a specific minute interval used in the 
TradeStationTM chart.  This could be helpful if you use the same workspace file with same symbol 
mapping but have a different strategy for a different interval.  Most users will keep this setting as Any. 
 

 

Check Duplicate Signals 
 

 

Signals/Order Type Mapping 

 
This section allows mapping order types that are not recognized by StoneX Futures but are in 
TradeStationTM.  An example of this would Buy to Cover or Sell Short.   
To add a new order type mapping for all or particular signal names, click on Add.  To view current 
mappings, click on Mappings. 
 

 

When you add a new order type mapping, a new entry will appear.  Pick the signal name from the 
drop-down list and select New… under Order Type Mapping in the drop down list. 
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Name the order type mapping and choose how StoneX Futures Trader should send the order for 
execution.  (Eg. Send Buy-to-Cover Limit as Buy Limit). 

 

Below is an example mapping BUY and SELL signal using the custom StoneX Futures mapping and 
the EXIT signal using the Standard mapping. 
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Process 
 

1. Insert the 
EasyLanguage 
strategy in the 
“Chart Analysis” 
window in 
TradeStationTM. To 
enable the Strategy 
in TradeStationTM, 
right click in chart 
and go to Format 
Strategies.  Then, 
activate Generate 
strategy orders… 
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2. Login to StoneX Futures Trader and ensure AutoX is enabled.  Go to File > Plugins > 
AutoX > Capture Activated (checked) 

 

(connected) 

 
 

(disconnected) 

 
 
 

3. Catch and confirm (if “Manual Confirmation” is checked) the signals from TradeStationTM in 
StoneX Futures Trader.  The signal name and interval of the base chart is located in 
comments of the StoneX Futures Trader order. 

 
 

 
 

Log 
A log of TradeStationTM interaction is stored to file and can be viewed inside the StoneX Futures 
Trader using the 
AutoX Log window.  To view this window go to:  File  > Plugins > AutoX > Log 
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Queued Messages 
All TradeStationTM messages are queued in the case of a disconnection to StoneX Futures Servers 
and pushed to execution after a successful reconnection. In addition, StoneX Futures Trader pre‐
processes the queued messages with following rules: 
 

1. If queue contains Active message and corresponding Cancel is incoming, no order will be 
sent on reconnection. 

2. If queue contains Active message and corresponding Replace is incoming, modified 
version of order will be issued instead of original one 

 
3. If queue contains Active or Replace message and corresponding Filled is incoming, market 

order will be issued. 
4. If queue contains two Active messages with equal quantity, workspace, interval, symbol and 

both marked as “Send as MKT”, these orders will be removed from queue (“closed in 
order received”)  

 
To view the current queued messages, go to File > Plugins > AutoX > Queued Orders. 
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TradeStationTM Email format: 

Example of a new order email notification: 
 
TradeStation - Strategy Active Order for NQM07 
 
Order: Buy 1 NQM07 @ 1834.00 Stop Market 
Account: 
Occurred: 4/13/2007 4:24:06 PM 
Signal: NewHi 
Interval: 1 min. 
Workspace: C:\Program Files\TradeStation 8.2 (Build 3894)\MyWork\TEST 

Example of a cancel request notification: 
 
TradeStation - Strategy Canceled Order for NQM07 
 
Order: Buy to Cover 1 NQM07 @ 1834.00 Stop Market 
Account: 
Occurred: 4/13/2007 4:27:06 PM 
Signal: NewHi 
Interval: 1 min. 
Workspace: C:\Program Files\TradeStation 8.2 (Build 3894)\MyWork\TEST 
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